
Building Your First Collection 

Building Your First Collection  

This tutorial leads you through the process of adding items to your first CONTENTdm collection with the 
Project Client. To successfully complete this section: 

 The CONTENTdm server must be running. 

 The Project Client must be installed on your desktop computer.  

 You have set up a collection and are ready to begin adding items into the collection.  

This guide is intended to provide a quick start for your collection building with the Project Client. You can 
also add new items with the CONTENTdm Web interface, which is detailed in Adding Items. Additional 
assistance in using specific CONTENTdm features is available in the Help files. 

Learn About: 

Section I:  Creating a Project 

Section II:  Editing Project Settings 

Section III:  Adding Items to a Project 

  Adding an Item  

Adding a URL 

Adding Multiple Items  

Section IV:  Entering Metadata 

Using the Project Spreadsheet  

Using the Item Editing Tab 

Section V:  Uploading Items for Approval 

Section VI:  Approving Items  

 

Section I: Creating a Project 

The Project Client enables you to create and work with projects. When you add items to the Project Client 
and edit metadata using the Project Spreadsheet and other tools, items are saved as a part of the project. A 
project also reflects a group of Project Client settings associated with a collection on a CONTENTdm 
Server. These settings and the Project Client interface make it efficient to add items and metadata to your 
collection. 

Projects are workspaces where you will add items and descriptive metadata before you add them to a 
collection. Once an item is in a project, it will remain in your project until it is uploaded. Opening and closing 
a project does not affect the items within the project. 

When you upload items for approval from the Project Client your items are sent to a pending queue for 
review by a CONTENTdm Administrator who then adds approved items to a collection. 

Before you begin, the Project Client software must be installed on your workstation. You will need the 
following information from your CONTENTdm Administrator:  

 URL address of the CONTENTdm server 

 your user name and password 
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The New Project wizard in the Project Client guides you through creating a project. This section explains 
each dialog in the wizard.  

To create a new project:  

1. From the Project Client Home tab, click Create New Project. The New Project wizard displays. Enter 
the CONTENTdm Server URL which can begin with either http or https protocols. Then enter your user 
name and password. Click Next. 

 

Figure 1. New Project URL and Login 

2. Click the dropdown list to view the existing collections on the server. Select the collection where you will 
upload items. When you upload items from your project to the collection, they will always go into the 
pending queue of the specified collection to await approval by the collection administrator. Click Next.  
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Figure 2. Choose Collection 

3. Name your project or review the name provided. Project names should not exceed 128 characters 
(including spaces) and alphanumeric characters should be used. Project names are used within the 
Project Client to help you organize you work; they are not displayed to end users. Click Finish.  

To make a project available to other Project Client users, check Share this project on a network 
with other users. If you plan to share a project, be sure to use a unique name since other users 
cannot import any project that uses the same name as one of their existing projects. Click Browse to 
locate or create a shared location that is accessible to other users. Click Finish. If different users need 
to have slightly different project settings to work with the same collection or need to work 
simultaneously, set up separate projects instead of sharing. 

When you create a shared project, the project settings and the items you add to the project are saved 
to the shared location you specify so others can also work in the project.  

Only one user at a time can work with a shared project. If you opt to share your project, remember that 
deleting items or changing settings affects all users who share the project. If you delete a shared 
project from your Project Client, it remains available to other Project Client users at the shared network 
location. To completely delete a shared project, the project directory must be deleted from the shared 
network location.   
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Figure 3. Naming and Sharing 

4. Once you have successfully created a project, the Project Client Home tab displays and you can begin 
adding items to your project.  

In the example shown below the Collection name is displayed in the left task pane as Collection 1 and 
the project name, Project 1 appears below it. Next to the project name, an icon showing two figures 
indicates that this project is shared.  

 

Figure 4. Home tab with Collection and Project Name 
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Section II: Editing Project Settings 

Once your new project is created you can establish or review your project settings in the Project 
Setting Manager before you begin adding items. The Project Settings Manager is a centralized 
interface for viewing and editing many project settings that can make working in the Project Client 
more efficient.    

Default project settings match collection configuration and server settings in CONTENTdm 
Administration. As you work in the Project Client, the project-level settings that you save in the 
Project Settings Manager will override the default settings.  

Some settings are established at the collection level by the server or collection administrator and 
can be viewed but not changed in the Project Settings Manager.  

Use the Metadata Templates in the Project Settings Manager to establish a metadata template before you 
add items to the project. 

To edit project settings: 

1. From the Home tab or the Project tab, in the left task pane under Other Tasks, click Edit Project 
Settings or from the Project menu, click Project Settings Manager and navigate to the page you 
need.   

 

Figure 5. Edit Project Settings 

For more information on establishing or editing your project settings, see About Project Settings. 

Section III: Adding Items to a Project 

When you add items to your project, you can enter or edit metadata then upload items to the CONTENTdm 
server for approval before they are added to your collection.  

Items can be added to your project from any of the following  
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 Home tab 

 Project tab or 

 Add menu.  

On the Home or Project tabs use the left task pane options under Common Tasks to add items (images, 
compound objects, audio or video files) to your project.  

 

Figure 6.  Adding Items 

The Add menu includes additional, less common, items (finding aid and URL) to add to your project.  

 

Figure 7. Add Menu 

Adding an Item 

To add an item, select the specific file to add into the project spreadsheet. CONTENTdm adds a copy of the 
item to the project, and in the process creates a thumbnail image, or uses a custom thumbnail image that 
you create, or uses a default thumbnail image for each file, depending on your settings.  

Once you have added a file into the project spreadsheet, you can edit or add metadata for that file. 

To add an item: 

2. On the Home or Project tabs, click Add Item from the left task pane or from the Add menu select 
Item. The Add Item wizard opens. 
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Figure 8. Add an Item 

3. To locate the item you want to add, click Browse.  

 Select the item you want add or  

 Select multiple items to add from a single directory by pressing CTRL and clicking additional items.    

4. Click Open.  The browse screen closes and the file path and name of the selected item are displayed in 
the Add Items wizard.  

Specify whether CONTENTdm should create a display image. You can specify the display image format 
in the Project Settings Manager by editing the Images & Thumbnails settings. (If your collection 
administrator has enabled Archival File Manager, this screen will have a different appearance from 
the one shown above.) 

Creating display images is useful when you are working with high-resolution images which are very 
large and minimally (or un-) compressed. CONTENTdm can create display-quality versions of images 
when you add high-resolution files, minimizing file download time for end-users and eliminating the 
need to store these large, uncompressed high resolution files on your CONTENTdm server.  

5. Click Add.  A progress screen displays as the item is added. A summary screen displays when the 
addition is complete.  

6. Click Close to close the summary screen. The item is displayed in the project spreadsheet. Enter 
metadata in the project spreadsheet or click the item thumbnail to open the Item Edit tab.  

Adding a URL 

Adding a URL allows you to add a Web site to your project spreadsheet. This function is often used to 
manage metadata describing streaming media. It also allows you to add metadata for Web sites. A system 
default thumbnail is used for URLs if you choose not to create custom thumbnail images for these file types.  
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This function can also be used to add a null item—that is, a metadata record with no associated digital file. 
Adding a null item is useful in cases where item metadata is ready to be added to your project, but the 
digital item is not available.  

To add a URL or null item: 

1. From the Add menu, click URL.  

 

Figure 9. Add URL 

2. The Add URL screen displays. Select Import URL and type the complete URL, into the dialog box and 
click Add. Or select Import null item.  

3. Click Add. The Add URL screen closes and the project spreadsheet displays.    

4. Enter metadata in the project spreadsheet or click the item thumbnail to open the Item Edit tab.  

Adding Multiple Items 

This tutorial focuses on the simplest method for adding multiple items; other tutorials describe more 
complex operations in detail, such as adding multiple items with tab delimited text or adding compound 
objects.  

It is often more efficient to add items in batches. Some organizations perform their scanning and image 
processing work ahead of time, and then add batches of items to the Project Client. A staggered workflow 
can help you to take advantage of some of the Project Client settings that make it more efficient to add 
many items at once. If you are adding multiple items that have common metadata, use the metadata 
templates to create your metadata before adding items.  

Before you add multiple items, all the files you want to add must be stored in a single directory. When you 
add items to the Project Client, a thumbnail image is created for each item. The Project Client will first try to 
create a thumbnail image based on the actual item you add. So for example, if you add a video, the Project 
Client will attempt to render the first frame of your video file as the thumbnail image for that item. If the 
first frame cannot be rendered then a standard CONTENTdm thumbnail image for that file type will be used.  

You can also customize thumbnail images for all file types if, for example, you want all oral histories to be 
represented by the same thumbnail image.  

To add multiple files: 

1. The files you want to add must be in a single directory. Navigate to the Home tab or Project tab 

2. On the left task pane under Common Tasks, click Add Multiple Items. The Add Multiple Items wizard 
opens.  
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3. Select from the two options:  

 Import from a directory. (This method is the focus of the tutorial.) 

 Import using tab-delimited text file. To add items using this method, not only must all items be in 
one directory, you must also have a tab-delimited text file that lists the files and contains metadata 
about the files that are being added. For more information about this type of import, see Adding 
Compound Objects with Tab-delimited Text.  

4. Click Browse to select the directory containing the files you want to import. Once you have opened the 
directory, click OK and then click Next. 

 

Figure 10. Adding Multiple Files from a Directory 

5. Specify whether CONTENTdm should create a display image. (If your collection administrator has 
enabled Archival File Manager, this screen will have a slightly different appearance from the one 
shown below.) 
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Figure 11. Display Image Settings 

If you select Yes, and you want to specify display image settings, click Image Options. This opens the 
Images & Thumbnails settings in the Project Settings Manager.  

Creating display images is useful when you are working with high-resolution images which are very 
large and only minimally (or un-) compressed. CONTENTdm can create display-quality versions of 
images when you add high-resolution files, minimizing file download time for end users and eliminating 
the need to store these large, uncompressed high resolution files on your CONTENTdm server.  

6. Click Next. The Confirm Settings screen displays import information. 
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Figure 12. Confirm Settings 

Review the settings and click Add Items. Or click Back to make changes.  

A progress screen displays as the items are added to your project. When complete a summary screen 
displays to show any errors or warnings. 

  

Figure 13. Summary 
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7. Click Close. The items are displayed in the project spreadsheet. You are now ready to enter metadata.  

Section IV: Entering Metadata 

Once items are added to your project, metadata can be entered one item at a time by typing text directly 
into the project spreadsheet or Item Edit tab.   

Using the Project Spreadsheet 

The project spreadsheet is displayed when you click on the Project tab. To add or edit metadata, click the 
cell you want to change and then type your text. 

To replicate the text of one cell to other cells within the same column, right-click on a cell and choose Fill 
Down, Fill Up, or Fill All (fills both above and below in the same column). This function is also available by 
selecting Fill from the Edit menu.   

 

Figure 14. Fill Menu Option 

Keyboard shortcuts within the project spreadsheet make it easier to enter metadata and 
perform common operations without using a mouse. 

To navigate within the cells: 

 Press Tab to close the current active cell and move one cell to the right.  

 Press Shift + Tab to close the current active cell and move one cell to the left.  

 Press Enter to close the current active cell and move down one row.  

 Press Ctrl + c to copy text from an outlined cell.  

 Press Ctrl + v to insert copied text into an outlined cell.  

 Press Ctrl + x to cut text from an outlined cell.  

 Press Ctrl + arrow key to move to the farthest cell in that direction.  

 Press Ctrl + Enter to insert a carriage return in the text in an active cell. This formatting is retained 
only when used in a full text field and the page text and page image are displayed side by side in 
the CONTENTdm Web interface. 

For more information about these features and more advanced metadata functions, such as the Project 
Settings Manager and using the Controlled Vocabulary, consult the Project Client Help files. 
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Using the Item Editing Tab 

You can open the Item Editing tab from the project spreadsheet. Up to 20 items at a time can be opened in 
Item editing tabs. The Item Editing tab provides access to view the item about which you are entering 
metadata. The Item Editing tab also has navigation to view the next and previous items without returning to 
the project spreadsheet.  

To use the Item Editing tab to enter metadata for an item: 

1. Click on the thumbnail image of the item in the project spreadsheet to open the Item Editing tab or 
select the checkbox next to the item or items and click Open in Tab.  

2. Type the text you want to associate with each field into the corresponding text box.  
 
If a selected field is governed by a Controlled Vocabulary, the Controlled Vocabulary pane will display all 
items allowed for that field. 

3. Once you have finished entering data, click Save to keep your changes. 

 Save & Next commits your changes, closes the current item, and opens the following item in the 
project spreadsheet 

 Save & Back commits your changes, closes the current item, and opens the preceding item in the 
project spreadsheet.   

 

Figure 15. Item Editing Tab 

 Administrative metadata fields are displayed on a blue background. 
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 Warning and error icons are displayed in the far left column of the spreadsheet. Hovering over the 
icons displays information about the warning or error. 

o A red error icon indicates an error within a metadata field (such as a required field that 
contains no data) which must be resolved before the item can be uploaded to the pending 
queue.  

o A yellow warning icon indicates an error within a metadata field, such as a misspelling or 
use of a term not in the controlled vocabulary. Items with warning icons can be uploaded 
for approval but may still require edits from the collection administrator.  

 

Figure 16: Error and Warning Indictors 

Section V: Uploading Items for Approval 

New items are uploaded into your CONTENTdm database using:  

 HTTP or HTTPS (depending on your server URL)  

 Shared directory   

After you create a project, the upload method can be changed in the Project Settings Manager > Project 
Options screen.  

To upload items in your project: 

1. From the Project tab, select the items you want to upload by selecting the checkbox in each item 
row. Or click Select All.   

2. Click Upload for Approval. When uploaded, the images are transferred to the pending queue and 
are ready for review and final approval by the collection administrator before being added to the 
collection.   

 

Figure 17: Upload for Approval 
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Section VI: Approving Items  

Before new items are added to a collection, the items must be approved and indexed. You must have 
CONTENTdm administrator rights to approve items and build indexes. You can view or edit items before 
approving them by opening CONTENTdm Administration through the Project Client or through the Web. 

To view pending items from a project: 

1. Click Approve from the Administration menu.  

2. Enter your CONTENTdm user name and password. The Approve items screen is displayed and all items 
pending approval are shown.  

To view pending items from the Web (useful when working on machines where the Project Client 
is not installed): 

1. In your Web browser address bar, enter http://your.server.address/cgi-bin/admin/start.exe  

2. Enter your CONTENTdm user name and password when prompted.  

3. Click on the Items tab to access the Approve items screen. All pending items are shown.  

Tip: Some organizations find it useful to assign one person to be responsible for approving items before 
they are added to the collection. This is particularly helpful when you have multiple people entering 
metadata because one person verifies the accuracy and consistency of the items. 

 

Figure 18. Approve Items 
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Items that have been uploaded from Project Clients and are waiting for approval will appear on the Approve 
items screen. If the collection utilizes a controlled vocabulary, any new terms that are submitted for 
approval will also be on this page. Administrators may add, edit, or delete individual items in the pending 
queue. 

To work with Controlled Vocabulary: 

 To accept the new term and add it to the controlled vocabulary, click Add from the Detailed 
approval queue actions. 

Or: 

 To edit or delete the term within the item metadata,  click Edit next to the item with an asterisk 
from the pending items queue,  

 If the same term appears in the metadata of multiple items click Edit from the Detailed approval 
queue actions to view the Edit List. Click Edit next to the item that you wish to edit. This opens the 
item and metadata so you can view the term in context. Change the term within the item 
metadata. Click Approve to add the item to the collection.  

To view an item in the pending queue: 

 Click Edit next to the item that you want to view. The item opens and metadata fields are 
displayed and may be edited.  

To approve an item: 

 Click Approve at the bottom of the metadata page after making changes to the metadata.  

Approved items are added to the collection but do not become searchable until the text index is built.  

To approve and index all items in the pending queue: 

 Select Approve and index all and click go.  Approving and indexing all items may take several 
minutes.  When the two operations, approving and indexing are completed, no items remain in the 
queue for approval. 

 

 

Figure 19. No Pending Items 

Once items are approved and the build of the text index is complete, the items are in the collection and can 
be searched and retrieved in the CONTENTdm Search Client. The figure below shows how an item will 
appear when it is retrieved in the CONTENTdm Search Client.  
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Figure 20. Viewing an Item 
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